Back to overview
Downtime

Some services are down

May 18 at 05:59pm EDT
Affected services
Tautulli (plex watch stats)

Resolved
May 18 at 06:23pm EDT

downgraded tautulli until the issue can be resolved

Created
May 18 at 05:59pm EDT

error after updating tautulli, working on it